Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2025 - 23:00 CET
Scheduled
We are performing scheduled maintenance for the Scalable login on March 12th. These are scheduled to last from 23:00 to midnight. Please follow the instructions in the app to authenticate during the maintenance work. It will not be possible to change password, email address or personal data during this time. Thank you for your understanding.
Posted Mar 11, 2025 - 17:27 CET
This scheduled maintenance affected: App (iOS, Android, Web).