Video Identification Germany and Austria
Incident Report for Scalable Capital
Resolved
This incident has been resolved.
Posted Mar 10, 2023 - 15:19 CET
Identified
We are currently investigating possible technical limitations with the video identification for Germany and Austria. In Germany, please use the option to identify yourself via e-ID or at the Deutsche Post branch in the meantime. We are working with our partner to find a timely solution.
Posted Mar 10, 2023 - 14:58 CET
This incident affected: Identification (Video Identification (Germany and Austria)).