Munich stock exchange: trading affected
Incident Report for Scalable Capital
Resolved
This incident has been resolved.
Posted Jun 03, 2024 - 17:47 CEST
Identified
There are currently no quotes for shares with the home exchange New York Stock Exchange (NYSE) on the Munich stock exchange. Orders may therefore be executed with a time delay.
Trading is still possible for
- All other securities
- This security on other exchanges (depending on listing)
Posted Jun 03, 2024 - 17:19 CEST
This incident affected: Exchanges (Munich Stock Exchange).