Longer loading times
Incident Report for
Scalable Capital
Resolved
This incident has been resolved.
Posted
Apr
09
,
2025
-
21:08
CEST
Identified
Currently, there may be longer loading times. We are working at full speed to find a solution.
Posted
Apr
09
,
2025
-
20:24
CEST
This incident affected: App (iOS, Android, Web).
×
Subscribe to Incident
Subscribe to updates for
Longer loading times
via . You'll receive .
By subscribing you agree to our
Privacy Policy
.