Munich stock exchange: trading affected
Resolved
This incident has been resolved.
Posted Apr 09, 2025 - 21:35 CEST
Identified
There may currently not be quotes for shares on the Munich stock exchange. Orders may therefore be executed with a time delay.
Trading is still possible for
- All other securities
- This security on other exchanges (depending on listing)
Posted Apr 09, 2025 - 21:34 CEST
This incident affected: Exchanges (Munich Stock Exchange).