Note
Incident Report for Scalable Capital
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 12:20 CET
Identified
We are currently investigating possible technical limitations. We will keep you updated on any possible impairments via this page.
Posted Nov 14, 2023 - 12:10 CET
This incident affected: App (iOS, Android, Web).