Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 18, 2024 - 22:00 CEST
Scheduled
We are performing scheduled maintenance for the Scalable login on 18.09.2024. These are scheduled to last from 22:00 to 23:00. Please follow the instructions in the app to authenticate during the maintenance work. It will not be possible to change password, email address or personal data during this time. Thank you for your understanding.
Posted Sep 18, 2024 - 13:20 CEST
This scheduled maintenance affected: App (iOS, Android, Web).