European Investor Exchange: trading disrupted
Resolved
This incident has been resolved.
Posted Apr 04, 2025 - 12:19 CEST
Identified
Only European Investor Exchange affected: The trading venue may be available to a limited extent. This is due to technical problems.
Other venues are not affected.
Orders on European Investor Exchange may temporarily
- not be created,
- not be cancelled and/or
- not be executed on the exchange.
Posted Apr 04, 2025 - 11:06 CEST
This incident affected: Exchanges (European Investor Exchange).