Delayed display of transactions

Incident Report for Scalable Capital

Resolved

This incident has been resolved.
Posted Apr 07, 2025 - 11:18 CEST

Identified

Displaying and updating of transactions may be delayed. Order execution on the venues is not affected. We are working on a quick solution.
Posted Apr 07, 2025 - 10:05 CEST
This incident affected: Custody account (Baader Bank, Scalable Capital).