Chat not available
Incident Report for Scalable Capital
Resolved
This incident has been resolved.
Posted Nov 10, 2023 - 17:48 CET
Identified
Currently our chat is not available. Please send us an email to service@scalable.capital or call us in urgent cases via phone number +49 89 380 380 67.
Posted Nov 10, 2023 - 10:18 CET
This incident affected: Client Support (Chat GER/AT, Chat FR, Chat ES, Chat IT).