Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 20, 2026 - 19:30 CET
Scheduled
We are performing scheduled maintenance from 20.02.2026 - 19:30 (CET) to 23.02.2026 - 07:00 (CET). During this time, pay-ins via "Instant" will not be possible. Regular bank transfers are not affected. Thank you for your understanding.
Posted Feb 20, 2026 - 09:19 CET
This scheduled maintenance affects: App (iOS, Android, Web).