Note

Incident Report for Scalable Capital

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 16:18 CET

Investigating

We are currently investigating possible technical limitations. We will keep you updated on any possible impairments via this page.
Posted Mar 03, 2025 - 15:55 CET
This incident affected: App (iOS, Android).