Note

Incident Report for Scalable Capital

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 12:28 CET

Investigating

We are currently investigating possible technical limitations. We will keep you updated on any possible impairments via this page.
Posted Feb 28, 2025 - 12:20 CET
This incident affected: App (iOS, Android, Web).