Payments are delayed

Incident Report for Scalable Capital

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 12:16 CEST

Identified

We are currently experiencing an issue that is causing delays in the processing of SEPA Credit Transfer deposits, SEPA direct debits, instant payments and withdrawals. This may result in longer than expected processing times for these payments. Our team is investigating the problem and working to resolve it as quickly as possible.
Posted Jul 22, 2025 - 18:58 CEST
This incident affected: Custody account (Scalable Capital).