Phone support partially unavailable

Incident Report for Scalable Capital

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 18:46 CEST

Identified

Our support services are currently partially disrupted due to a technical issue.
In the meantime, you can reach us via email at service@scalable.capital.

We are working at full speed to find a solution. Thank you for your understanding.
Posted Sep 16, 2026 - 11:04 CEST
This incident affected: Client Support (Phone).