Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 23, 2024 - 08:00 CET
Scheduled
We are performing scheduled maintenance on the 23.11.. This is scheduled to last from 08:00 - 14:00. During the maintenance work, our Broker web customer area and mobile apps might experience intermittent disruptions.
Posted Nov 22, 2024 - 10:23 CET
This scheduled maintenance affected: App (iOS, Android, Web).