Trading disrupted
Incident Report for Scalable Capital
Resolved
This incident has been resolved.
Posted May 08, 2024 - 16:53 CEST
Identified
Trading may currently be available to a limited extent. This is due to technical problems. Please submit your instructions as soon as technically possible.

Orders may temporarily
- not be created,
- not be cancelled and/or
- not displayed with the most recent status.

Orders that have already been placed can still be executed on the exchanges.
Posted May 08, 2024 - 16:27 CEST
This incident affected: Custodian Bank.