Munich stock exchange: trading affected
Incident Report for Scalable Capital
Resolved
This incident has been resolved.
Posted Mar 13, 2023 - 18:32 CET
Identified
There are currently some delays in quotes for stocks on the Munich stock exchange. Orders may therefore be executed with a time delay.
Trading is still possible for
- All other securities
- This security on other exchanges (depending on listing)
Posted Mar 13, 2023 - 17:34 CET
This incident affected: Exchanges (Munich Stock Exchange).