Possible delay in the execution of the savings plan
Incident Report for
Scalable Capital
Resolved
This incident has been resolved.
Posted
Oct
04
,
2024
-
17:29
CEST
Identified
There may be some delays in the execution of savings plans with instruction date on 1. October. Affected savings plans will be automatically executed at the earliest possible date.
Posted
Oct
01
,
2024
-
13:13
CEST
×
Subscribe to Incident
Subscribe to updates for
Possible delay in the execution of the savings plan
via . You'll receive .
By subscribing you agree to our
Privacy Policy
.