Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 24, 2026 - 23:30 CEST
Scheduled
We are performing scheduled maintenance on 24.06.2026. This is scheduled to last from 23:30 (CEST) to 01:30 (CEST) on 25.06.2026. During the maintenance work, our web customer area and mobile apps will not be fully available. Thank you for your understanding.
Posted Jun 22, 2026 - 15:09 CEST
This scheduled maintenance affected: App (iOS, Android, Web).