Phone not available
Incident Report for Scalable Capital
Resolved
This incident has been resolved.
Posted Jan 11, 2023 - 11:00 CET
Identified
We are currently not available by phone in Germany and Austria. Please contact us via email at service@scalable.capital or use the chat function on our website or the app.
Posted Jan 11, 2023 - 10:55 CET
This incident affected: Client Support (Phone).